RSS modules - field editors not showing for some feeds | Plikli Modules | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
RSS modules - field editors not showing for some feeds
Avatar
Mark
Member
Members
Forum Posts: 8
Member Since:
April 29, 2018
sp_UserOfflineSmall Offline
1
May 11, 2018 - 8:57 pm
sp_Permalink sp_Print

see here - there are no editors for the fields:

View post on imgur.com

But, when I examine the feed, it has the same structure as the ones that do have editors.

The RSS feed is here:
http://feeds.feedburner.com/an.....ientlights

Avatar
redwine
Admin
Forum Posts: 214
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
2
May 16, 2018 - 1:12 am
sp_Permalink sp_Print

I tested this feed on both localhost and live server and the result is the same; the feeds structure is not available to select. I tested the Plikli feed using the same feedburner
https://www.plikli.com/feed/
and http://feeds.feedburner.com/Plikli
They both worked as intended!

I can't tell why, but during my extensive work on the RSS module, I encountered some tough problem which is related to specific sites. Example:
some sites have their RSS feed work on live servers but not accessible on localhost, even when their feed link is not https.

As i Mentioned about the RSS module, it works well after I fixed few things in it and provided the correct instruction to also make it work through a Cron job because it was in demand. However, this module should retire soon and a new one, more friendly and better written, will replace it!

Avatar
Brian
Member
Members
Forum Posts: 3
Member Since:
August 29, 2018
sp_UserOfflineSmall Offline
3
August 29, 2018 - 11:05 pm
sp_Permalink sp_Print

I've had this issue as well for many feeds. I have a work around. Simply take a feed that works, you must have one, use title, description and link, then remove it, add the feed that wasn't working. It's still the same data, tho you cannot click it, the feed will syndicate properly.

Avatar
redwine
Admin
Forum Posts: 214
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
4
August 30, 2018 - 3:48 am
sp_Permalink sp_Print

It might work temporarily. There are some sites that their feeds cannot be imported outside their subscription, no matter what server you are on or the protocol. You get what is shown in the picture and for most, nothing shows up in the fields and an error is thrown in the error log file.

This module was broken since Pligg time, and I fixed some of the most critical issues in it and namely how to import feeds using a cron job and provided accurate instructions in the readme file of the module.

I am using it via a cron job and my links table is now over 500 MB.

Forum Timezone: Asia/Beirut

Most Users Ever Online: 8

Currently Online:
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

john: 47

Nishant kumar: 30

Mosage: 25

Martin Gold: 22

StaticMove: 13

Hariom Balhara: 9

Mark: 8

Zona Info: 8

ugryzh: 7

Marcus Vinicius: 7

Newest Members:

Zona Info

Offertalink

Shivam Kumar

aydin

adityajawla

aditya

yami

DotGuy

Brian

Juan

Forum Stats:

Groups: 1

Forums: 8

Topics: 63

Posts: 426

 

Member Stats:

Guest Posters: 0

Members: 43

Moderators: 1

Admins: 1

Administrators: redwine

Moderators: Kshitij Kumar