*** SOLVED: USER WAS USING A DIFFERENT HTACCESS FILE AND HIS ISSUE WAS SOLVED WHEN HE USED THE ONE DISTRIBUTED WITH PLIKLI CMS *** Manual installation now working but with few issues | General Support | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
*** SOLVED: USER WAS USING A DIFFERENT HTACCESS FILE AND HIS ISSUE WAS SOLVED WHEN HE USED THE ONE DISTRIBUTED WITH PLIKLI CMS *** Manual installation now working but with few issues
This topic is locked
Avatar
Martin Gold
Member
Members
Forum Posts: 22
Member Since:
June 21, 2018
sp_UserOfflineSmall Offline
1
June 25, 2018 - 8:50 am
sp_Permalink sp_Print

Hello admin,
I have installed plikli cms manually and its working very fine on my website dropagist.com but please the categories and internal footer links when clicked on redirects to a 404 page;you can check that out as well and please help me out with which file to edit to change my dropdown to vertical line position.
Thanks

Avatar
redwine
Admin
Forum Posts: 184
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
2
June 25, 2018 - 12:50 pm
sp_Permalink sp_Print sp_EditHistory

your URLs show that you are using SEO URL Method 2. Have you renamed htaccess.default to .htaccess and edited it as indicated?

I see that when you click on a link, you get 404 error:

"The requested URL /new/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

notice that the "/new/" is missing the protocol and domain parts!

Give all details about your dashboard setting with regards to SEO and explain about the htaccess file.

I also see you have https enabled. Have you installed Plikli CMS while it was enabled?

Avatar
Martin Gold
Member
Members
Forum Posts: 22
Member Since:
June 21, 2018
sp_UserOfflineSmall Offline
3
June 25, 2018 - 11:03 pm
sp_Permalink sp_Print

Yea actually I have switched my seo to 2 and renamed the htaccess.default to default but don't know what to edit in it . please advice me on what to do and where to edit in the htaccess file.
Thanks

Avatar
redwine
Admin
Forum Posts: 184
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
4
June 26, 2018 - 1:28 pm
sp_Permalink sp_Print

You did it again and did not answer the question about https "I also see you have https enabled. Have you installed Plikli CMS while it was enabled?"

I see that you restored the SEO URL method to its default 1, and it is working. So it is definitely an htaccess issue.

You have https enabled and this means that there is an htaccess file with a "RewriteRule" to redirect all http to https.

Now, let's go through it step by step and I need you to answer all the questions, otherwise, it will be like your other posts, dragging and looping and this will force me to stop the support!

1- What did you do after you enabled SEO URL method 2 in the dashboard? The note in the setting says:
"Note: You must rename htaccess.default to .htaccess AND EDIT IT WHERE MODIFICATIONS ARE NOTED!"

did you rename htaccess.default to .htaccess?

because you had an .htaccess file to enable https, did you get a notification that a file exists?

Now, set the SEO URL method to 2 and follow the below steps.

If you had an htaccess file before you rename the htaccess.default, do the following:

A- rename the .htaccess file that is not from Plikli, from .htacess to htaccess.original
B- rename htaccess.default to .htaccess
C- Open htaccess.original and only copy the part that redirects to https (it should be 2 to 3 lines)
D- Open .htaccess and paste what you copied right after LINE 11 (RewriteEngine on). Save the file and try to navigate your site.

Your answer should include details about each of the above steps.

Avatar
Martin Gold
Member
Members
Forum Posts: 22
Member Since:
June 21, 2018
sp_UserOfflineSmall Offline
5
June 28, 2018 - 12:33 am
sp_Permalink sp_Print

I don't have the htaccess.original file in my cpanel just the htaccess.default only. Well I want to know if I should continue using the Seo 1, Can I my contents display the titles on search engines?
Exmple:- https://pasteboard.co/HrT5ZLS.png
Thanks

Avatar
redwine
Admin
Forum Posts: 184
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
6
June 28, 2018 - 2:10 pm
sp_Permalink sp_Print

Martin,

I did not ask you if you have htaccess.original. I said:

"If you had an htaccess file before you rename the htaccess.default, do the following:

A- rename the .htaccess file that is not from Plikli, from .htacess to htaccess.original
B- rename htaccess.default to .htaccess
C- Open htaccess.original and only copy the part that redirects to https (it should be 2 to 3 lines)
D- Open .htaccess and paste what you copied right after LINE 11 (RewriteEngine on). Save the file and try to navigate your site."

Do you have, other than htaccess.default, an .htaccess file?

Avatar
redwine
Admin
Forum Posts: 184
Member Since:
February 21, 2018
sp_UserOfflineSmall Offline
7
July 15, 2018 - 4:52 pm
sp_Permalink sp_Print

Final post about this issue.

USER DISREGARDED THE INSTRUCTIONS AND DRAGGED, TWO TOPICS ABOUT THE SAME SUBJECT, FOR TOO LONG.

HE ENDED UP USING THE HTACCESS THAT IS DISTRIBUTED WITH PLIKLI CMS AND THE ISSUE IS SOLVED.

READ ALSO THIS TOPIC THAT IS OPENED BY HIM:

https://www.plikli.com/forum-2/general-support/unable-to-customize-htaccess-for-seo-2-method/

This topic is locked
Forum Timezone: Asia/Beirut

Most Users Ever Online: 8

Currently Online:
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

john: 40

Mosage: 25

Martin Gold: 22

Nishant kumar: 21

StaticMove: 13

Hariom Balhara: 9

Zona Info: 8

Mark: 7

ugryzh: 7

Marcus Vinicius: 7

Newest Members:

Sadmir

linkers

Zona Info

Hariom Balhara

Nishant kumar

hari

Ijack

ugryzh

vrack

awoqo

Forum Stats:

Groups: 1

Forums: 8

Topics: 54

Posts: 368

 

Member Stats:

Guest Posters: 0

Members: 32

Moderators: 1

Admins: 1

Administrators: redwine

Moderators: Kshitij Kumar